Truck brake issue

Thread starter #1
I’m not sure what this part is called but will post a picture of it. Noticed when doing pretrip it was leaking when I released the tractor brakes. Lost about 60psi in less than one minute. Red circle is part, yellow line is where it’s leaking. If anyone could tell me the name of the part I’d greatly appreciate it.
 

Attachments

GAnthony

Well-Known Member
Supporter
#2
can't recall right now the part, but that yellow line, looks very much like a line i had a leak at. it is a "push-in-and lock" line

you may be able to push it in to reset it into the lock collar. but i think the lock collar may be broken. simple replacement from what i recall.
 

gearjammer

jammer
Staff member
Supporter
#3
can't recall right now the part, but that yellow line, looks very much like a line i had a leak at. it is a "push-in-and lock" line

you may be able to push it in to reset it into the lock collar. but i think the lock collar may be broken. simple replacement from what i recall.
I think he is talking about the yellow at the base
 
Thread starter #6
can't recall right now the part, but that yellow line, looks very much like a line i had a leak at. it is a "push-in-and lock" line

you may be able to push it in to reset it into the lock collar. but i think the lock collar may be broken. simple replacement from what i recall.
Sorry I did mean the yellow line I drew at the bottom. I didn’t have many options for colors
 
Thread starter #7
yellow line, yellow base......wasn't really specific in his yellow...

besides, the base color looks more gold (to me) than yellow
Yes that’s what I meant. It kind of looks yellow to me. I wasn’t thinking about the yellow airline to it
 

Hammer166

Instigateur №166™
Supporter
#9
Sweet that looks exactly like the part. Thank you very much
You bet. Not an uncommon failure item. You can bypass it in an emergency, just be aware there will be a slight delay after you pull the knob before the brakes set.

But if you're in BFE when it fails, you do what you gotta do! BTDT
 

GAnthony

Well-Known Member
Supporter
#11
i actually did have that yellow plastic air line pop out on me, at my 3 rd stop of the night, about 3, maybe 4 years ago. i pushed in the airline, and i heard a faint click. it was enough to get me to finish my run and return, all the while, at each stop, i'd check that line to make sure it did not pop out.

when i got back, i went to the shop, showed the mechanic, he said most likely, the clip inside, broke, since they are plastic, it was common. he had simply replaced the clip.

my "connection block" was mounted on the back wall of the cab, not down lower (what looks like) in the o/p's pic.


and yeah, so i'm picky.....

whaddya gonna do about it...?????
lol