FREIGHTLINER 2011 DD15 LOSE OF POWER

AAL TRASNPORT

New Member
I have this problem of lost engine power. Especially uphill
check engine., And the engine light turns on along with this code spn2797 fault 4, that forces me to leave the road the engine is shaking. I turn off the engine for 5 minutes when turning back on everything works normal again.
The mechanic did a pair of diagnostics and he replaced some harness also the computer now we are about to change the injectors that would be a fairly large expense please appreciate any opinion about it
 

r3gulator3

Friendly Neighborhood Former Technician
Staff member
Supporter
Have them check the Venturi for carbon build up. Have them pull the egr hot pipe off and look into it with a flash light. I have seen chunks of carbon that look like pieces of coal in there.

Injectors are problematic on a DD15. So that wouldn't surprise me either.
 

dchawk81

Well-Known Member
Have them check the Venturi for carbon build up. Have them pull the egr hot pipe off and look into it with a flash light. I have seen chunks of carbon that look like pieces of coal in there.

Injectors are problematic on a DD15. So that wouldn't surprise me either.
Yah I just had the mechanic clean mine. It's a whole new engine (sortof) and I got my MPGs back.

With that thing clogged it won't even get out of its own way with an empty trailer.
 

marinamarlose

New Member
I have this problem of lost engine power. Especially uphill
check engine., And the engine light turns on along with this code spn2797 fault 4, that forces me to leave the road the engine is shaking. I turn off the engine for 5 minutes when turning back on everything works normal again.
The mechanic did a pair of diagnostics and he replaced some harness also the computer now we are about to change the injectors that would be a fairly large expense please appreciate any opinion about it
*****
hi there,
this problem is normal when you had already driven for so many miles, but if you are under proper maintenance and this issue showed every time then you need to check following things.
There are four things a gasoline engine requires to generate power and almost any engine problem will come down to something relating to one of these four factors. Let’s focus on each one of these topics individually, and also look into friction:

  1. Air: It could be due to the dirty or damaged air filter.
  2. Fuel: It could be a reason that fuel injectors are not working properly and engine not getting the fuel required to perform at optimum level.
  3. Compression: Compression level is also a reason for the power loss because low compression level causes the less power out come.
 
Last edited:

GAnthony

Well-Known Member
Supporter
*****
hi there,
this problem is normal when you had already driven for so many miles, but if you are under proper maintenance and this issue showed every time then you need to check following things.
There are four things a gasoline engine requires to generate power and almost any engine problem will come down to something relating to one of these four factors. Let’s focus on each one of these topics individually, and also look into friction:

  1. Air: It could be due to the dirty or damaged air filter.
  2. Fuel: It could be a reason that fuel injectors are not working properly and engine not getting the fuel required to perform at optimum level.
  3. Compression: Compression level is also a reason for the power loss because low compression level causes the less power out come.
  4. Spark: Fouled spark plugs could be the reason that engine is not performing at its full power while traveling through uphill.
its a diesel engine, this has no spark plugs.
 
Last edited:
Top