Dismiss Notice
Sign up for free today and you will immediately be able to post messages to the forum, hold private conversations with members, view all attachments, as well as be eligible for contests held on our forum. We also have additional forums only viewable by members, so
CLICK HERE and join today!

2000 International 4700 parking brake problems

Discussion in 'Truck Maintenance and Repair' started by Loonatic72, Jul 23, 2012.

  1. Loonatic72

    Loonatic72 New Member

    Likes Received:
    I recently purchased a 2000 International 4700 with brake issues. I had the previous owner bring it by a shop before I purchased it to see all the problems before I bought it. They mentioned that the master cylinder was bad that's why the abs light was on and that the parking brake needed a new switch. Well, that wasn't the case on either issue. I've replaced the master cylinder and the parking brake switch. It has a wet system that runs off the power steering pump. I recently changed the powersteering pump cause I wasn't getting much pressure. When the truck is in PB and the lever is pulled the hoses pressurize but the brake on the tail shaft of the tranny doesn't engage. I've tested the wires and noticed that there's no power change when the brake is engaged. I don't see any problems with fuses or relays. Is there a simple fix or a kit to make this a cable pull parking brake? Thanks for the help.
  2. Avatar

    Google AdSense Guest Advertisement

    to remove this ad.
  3. Racer X 69

    Racer X 69 Member

    Likes Received:
    The brake system is called Hydro Boost. It uses hydraulic pressure from the power steering system to boost the brake system pressure, much like the vacuum booster does on cars and pickups. And when the engine is not running and you step on the brake pedal you should hear an electric pump running. This is the backup system to provide brake system boost when the engine is not running, or if the steering pump should fail.

    Does that part of the brake system function?

    The "PB" part is separate from the service brakes, and is strictly a parking brake. If it is not engaging when the shift lever is placed in "PB" then you need to find out why. You mentioned that a shop said the switch was bad, and that the switch was replaced and the parking brake still does not engage. You also mentioned that there is no change in power in the wires when the brake is engaged, Trace the wires, and find out why. The power to the parking brake needs to change, and I would suspect that with the brake engaged there should be no power, and when it is released there should be power to the actuator that releases the parking brake.
    AlexGramm likes this.

Share This Page